Microsoft Excel 2010:
Enter Data Manually in Worksheet Cells

You have several options when you want to enter data manually in Excel. You can enter data in one cell, in several cells at the same time, or on more than one worksheet at the same time. The data that you enter can be numbers, text, dates, or times. You can format the data in a variety of ways. And, there are several settings that you can adjust to make data entry easier for you.

**IMPORTANT** If you can't enter or edit data in a worksheet, it might have been protected by you or someone else to prevent data from being changed accidentally. On a protected worksheet, you can select cells to view the data, but you won't be able to type information in cells that are locked. In most cases, you should not remove the protection from a worksheet unless you have permission to do so from the person who created it. To unprotect a worksheet, click Unprotect Sheet in the Changes group on the Review tab. If a password was set when the worksheet protection was applied, you must first type that password to unprotect the worksheet.

**Enter text or a number in a cell**

1. On the worksheet, click a cell.
2. Type the numbers or text that you want to enter, and then press ENTER or TAB.

  **TIP** To enter data on a new line within a cell, enter a line break by pressing ALT+ENTER.

**Enter a number that has a fixed decimal point**

1. On the File tab, click Options.
2. Click Advanced, and then under Editing options, select the Automatically insert a decimal point check box.
3. In the Places box, enter a positive number for digits to the right of the decimal point or a negative number for digits to the left of the decimal point.
   
   For example, if you enter 3 in the Places box and then type 2834 in a cell, the value will appear as 2.834. If you enter -3 in the Places box and then type 283, the value will be 283000.
4. On the worksheet, click a cell, and then enter the number that you want.

  **Note** Data that you typed in cells before selecting the Fixed decimal option is not affected.

  **TIP** To temporarily override the Fixed decimal option, type a decimal point when you enter the number.

**Enter a date or a time in a cell**

1. On the worksheet, click a cell.
2. Type a date or time as follows:
Microsoft Excel 2010:
Enter Data Manually in Worksheet Cells

- To enter a date, use a slash mark or a hyphen to separate the parts of a date; for example, type 9/5/2002 or 5-Sep-2002.
- To enter a time that is based on the 12-hour clock, enter the time followed by a space, and then type a or p after the time; for example, 9:00 p. Otherwise, Excel enters the time as AM.

TIP   To enter the current date and time, press CTRL+SHIFT+; (semicolon).

NOTES

- To enter a date or time that stays current when you reopen a worksheet, you can use the TODAY and NOW functions.
- When you enter a date or a time in a cell, it appears either in the default date or time format for your computer, or in the format that was applied to the cell before you entered the date or time. The default date or time format is based on the date and time settings in the Regional and Language Options dialog box (Control Panel). If these settings on your computer have been changed, the dates and times in your workbooks that have not been formatted by using the Format Cells command are displayed according to those settings.
- To apply the default date or time format, click the cell that contains the date or time value, and then press CTRL+SHIFT+# or CTRL+SHIFT+@.

Enter the same data into several cells at the same time

1. Select the cells into which you want to enter the same data. The cells do not have to be adjacent.

<table>
<thead>
<tr>
<th>TO SELECT</th>
<th>DO THIS</th>
</tr>
</thead>
<tbody>
<tr>
<td>A single cell</td>
<td>Click the cell, or press the arrow keys to move to the cell.</td>
</tr>
<tr>
<td>A range of cells</td>
<td>Click the first cell in the range, and then drag to the last cell, or hold down SHIFT while you press the arrow keys to extend the selection. You can also select the first cell in the range, and then press F8 to extend the selection by using the arrow keys. To stop extending the selection, press F8 again.</td>
</tr>
<tr>
<td>A large range of cells</td>
<td>Click the first cell in the range, and then hold down SHIFT while you click the last cell in the range. You can scroll to make the last cell visible.</td>
</tr>
<tr>
<td>All cells on a worksheet</td>
<td>Click the Select All button. Select All button</td>
</tr>
<tr>
<td></td>
<td>To select the entire worksheet, you can also press CTRL+A.</td>
</tr>
<tr>
<td></td>
<td>NOTE   If the worksheet contains data, CTRL+A selects the current region. Pressing CTRL+A a second time selects the entire worksheet.</td>
</tr>
<tr>
<td>Nonadjacent cells or cell ranges</td>
<td>Select the first cell or range of cells, and then hold down CTRL while you select the other cells or ranges.</td>
</tr>
</tbody>
</table>
Microsoft Excel 2010:
Enter Data Manually in Worksheet Cells

You can also select the first cell or range of cells, and then press SHIFT+F8 to add another nonadjacent cell or range to the selection. To stop adding cells or ranges to the selection, press SHIFT+F8 again.

NOTE You cannot cancel the selection of a cell or range of cells in a nonadjacent selection without canceling the entire selection.

An entire row or column

Click the row or column heading.

1. Row heading
2. Column heading

You can also select cells in a row or column by selecting the first cell and then pressing CTRL+SHIFT+ARROW key (RIGHT ARROW or LEFT ARROW for rows, UP ARROW or DOWN ARROW for columns).

NOTE If the row or column contains data, CTRL+SHIFT+ARROW key selects the row or column to the last used cell. Pressing CTRL+SHIFT+ARROW key a second time selects the entire row or column.

Adjacent rows or columns

Drag across the row or column headings. Or select the first row or column; then hold down SHIFT while you select the last row or column.

Nonadjacent rows or columns

Click the column or row heading of the first row or column in your selection; then hold down CTRL while you click the column or row headings of other rows or columns that you want to add to the selection.

The first or last cell in a row or column

Select a cell in the row or column, and then press CTRL+ARROW key (RIGHT ARROW or LEFT ARROW for rows, UP ARROW or DOWN ARROW for columns).

The first or last cell on a worksheet or in a Microsoft Office Excel table

Press CTRL+HOME to select the first cell on the worksheet or in an Excel list. Press CTRL+END to select the last cell on the worksheet or in an Excel list that contains data or formatting.

Cells to the last used cell on the worksheet (lower-right corner)

Select the first cell, and then press CTRL+SHIFT+END to extend the selection of cells to the last used cell on the worksheet (lower-right corner).

Cells to the beginning of the worksheet

Select the first cell, and then press CTRL+SHIFT+HOME to extend the selection of cells to the beginning of the worksheet.

More or fewer cells than the active selection

Hold down SHIFT while you click the last cell that you want to include in the new selection. The rectangular range between the active cell and the cell that you click becomes the new selection.

TIP To cancel a selection of cells, click any cell on the worksheet.

2. In the active cell, type the data, and then press CTRL+ENTER.
Microsoft Excel 2010:
Enter Data Manually in Worksheet Cells

TIP You can also enter the same data into several cells by using the fill handle to automatically fill data in worksheet cells.

Enter the same data on several worksheets at the same time

By making multiple worksheets active at the same time, you can enter new data or change existing data on one of the worksheets, and the changes are applied to the same cells on all the selected worksheets.

1. Click the tab of the first worksheet that contains the data that you want to edit. Then hold down CTRL while you click the tabs of other worksheets in which you want to synchronize the data.

   ![Worksheet Tabs]

   NOTE If you don’t see the tab of the worksheet that you want, click the tab scrolling buttons to find the worksheet, and then click its tab. If you still can’t find the worksheet tabs that you want, you might have to maximize the document window.

2. On the active worksheet, select the cell or range in which you want to edit existing or enter new data.

   TO SELECT
   DO THIS
   A single cell
   Click the cell, or press the arrow keys to move to the cell.
   A range of cells
   Click the first cell in the range, and then drag to the last cell, or hold down SHIFT while you press the arrow keys to extend the selection.
   You can also select the first cell in the range, and then press F8 to extend the selection by using the arrow keys. To stop extending the selection, press F8 again.
   A large range of cells
   Click the first cell in the range, and then hold down SHIFT while you click the last cell in the range. You can scroll to make the last cell visible.
   All cells on a worksheet
   Click the **Select All** button.
   Select All button
   ![Select All Button]
   To select the entire worksheet, you can also press CTRL+A.
   NOTE If the worksheet contains data, CTRL+A selects the current region. Pressing CTRL+A a second time selects the entire worksheet.
   Nonadjacent cells or cell ranges
   Select the first cell or range of cells, and then hold down CTRL while you select the other cells or ranges.
   You can also select the first cell or range of cells, and then press SHIFT+F8 to add another nonadjacent cell or range to the selection. To stop adding cells or ranges to the selection, press SHIFT+F8 again.
   NOTE You cannot cancel the selection of a cell or range of cells in a
Microsoft Excel 2010:
Enter Data Manually in Worksheet Cells

nonadjacent selection without canceling the entire selection.

<table>
<thead>
<tr>
<th>An entire row or column</th>
<th>Click the row or column heading.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><img src="image" alt="Diagram" /></td>
</tr>
<tr>
<td></td>
<td>1 Row heading</td>
</tr>
<tr>
<td></td>
<td>2 Column heading</td>
</tr>
</tbody>
</table>

You can also select cells in a row or column by selecting the first cell and then pressing CTRL+SHIFT+ARROW key (RIGHT ARROW or LEFT ARROW for rows, UP ARROW or DOWN ARROW for columns).

**NOTE** If the row or column contains data, CTRL+SHIFT+ARROW key selects the row or column to the last used cell. Pressing CTRL+SHIFT+ARROW key a second time selects the entire row or column.

<table>
<thead>
<tr>
<th>Adjacent rows or columns</th>
<th>Drag across the row or column headings. Or select the first row or column; then hold down SHIFT while you select the last row or column.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Nonadjacent rows or columns</th>
<th>Click the column or row heading of the first row or column in your selection; then hold down CTRL while you click the column or row headings of other rows or columns that you want to add to the selection.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>The first or last cell in a row or column</th>
<th>Select a cell in the row or column, and then press CTRL+ARROW key (RIGHT ARROW or LEFT ARROW for rows, UP ARROW or DOWN ARROW for columns).</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>The first or last cell on a worksheet or in a Microsoft Office Excel table</th>
<th>Press CTRL+HOME to select the first cell on the worksheet or in an Excel list. Press CTRL+END to select the last cell on the worksheet or in an Excel list that contains data or formatting.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Cells to the last used cell on the worksheet (lower-right corner)</th>
<th>Select the first cell, and then press CTRL+SHIFT+END to extend the selection of cells to the last used cell on the worksheet (lower-right corner).</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Cells to the beginning of the worksheet</th>
<th>Select the first cell, and then press CTRL+SHIFT+HOME to extend the selection of cells to the beginning of the worksheet.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>More or fewer cells than the active selection</th>
<th>Hold down SHIFT while you click the last cell that you want to include in the new selection. The rectangular range between the active cell and the cell that you click becomes the new selection.</th>
</tr>
</thead>
</table>

**TIP** To cancel a selection of cells, click any cell on the worksheet.

3. In the active cell, type new data or edit the existing data, and then press ENTER or TAB to move the selection to the next cell.

The changes are applied to all the worksheets that you selected.

4. Repeat the previous step until you have completed entering or editing data.

University of New Mexico
College of Education
Andrea Harvey
garciaa@unm.edu
To cancel a selection of multiple worksheets, click any unselected worksheet. If an unselected worksheet is not visible, you can right-click the tab of a selected worksheet, and then click Ungroup Sheets.

When you enter or edit data, the changes affect all the selected worksheets and can inadvertently replace data that you didn’t mean to change. To help avoid this, you can view all the worksheets at the same time to identify potential data conflicts.

1. On the View tab, in the Window group, click New Window.
2. Switch to the new window, and then click a worksheet that you want to view.
3. Repeat steps 1 and 2 for each worksheet that you want to view.
4. On the View tab, in the Window group, click Arrange All, and then click the option that you want.
5. To view worksheets in the active workbook only, in the Arrange Windows dialog box, select the Windows of active workbook check box.

Adjust worksheet settings and cell formats

There are several settings in Excel that you can change to help make manual data entry easier. Some changes affect all workbooks, some affect the whole worksheet, and some affect only the cells that you specify.

CHANGE THE DIRECTION FOR THE ENTER KEY

When you press TAB to enter data in several cells in a row and then press ENTER at the end of that row, by default, the selection moves to the start of the next row.

Pressing ENTER moves the selection down one cell, and pressing TAB moves the selection one cell to the right. You cannot change the direction of the move for the TAB key, but you can specify a different direction for the ENTER key. Changing this setting affects the whole worksheet, any other open worksheets, any other open workbooks, and all new workbooks.

1. On the File tab, click Options.
2. In the Advanced category, under Editing options, select the After pressing Enter, move selection check box, and then click the direction that you want in the Direction box.

CHANGE THE WIDTH OF A COLUMN

At times, a cell might display ######. This can occur when the cell contains a number or a date and the width of its column cannot display all the characters that its format requires. For example, suppose a cell with the Date format "mm/dd/yyyy" contains 12/31/2007. However, the column is only wide enough to display six characters. The cell will display ######. To see the entire contents of the cell with its current format, you must increase the width of the column.
Microsoft Excel 2010:
Enter Data Manually in Worksheet Cells

1. Click the cell for which you want to change the column width.
2. On the Home tab, in the Cells group, click Format.

### Change the Column Width

3. Under Cell Size, do one of the following:
   - To fit all text in the cell, click AutoFit Column Width.
   - To specify a larger column width, click Column Width, and then type the width that you want in the Column width box.

**NOTE** As an alternative to increasing the width of a column, you can change the format of that column or even an individual cell. For example, you could change the date format so that a date is displayed as only the month and day ("mm/dd" format), such as 12/31, or represent a number in a Scientific (exponential) format, such as 4E+08.

### Wrap Text in a Cell

You can display multiple lines of text inside a cell by wrapping the text. Wrapping text in a cell does not affect other cells.

1. Click the cell in which you want to wrap the text.
2. On the Home tab, in the Alignment group, click Wrap Text.

**NOTE** If the text is a long word, the characters won't wrap (the word won't be split); instead, you can widen the column or decrease the font size to see all the text. If all the text is not visible after you wrap the text, you might have to adjust the height of the row. On the Home tab, in the Cells group, click Format, and then under Cell Size click AutoFit Row.

### Change the Format of a Number

In Excel, the format of a cell is separate from the data that is stored in the cell. This display difference can have a significant effect when the data is numeric. For example, when a number that you enter is rounded, usually only the displayed number is rounded. Calculations use the actual number that is stored in the cell, not the formatted number that is displayed. Hence, calculations might appear inaccurate because of rounding in one or more cells.
Microsoft Excel 2010:
Enter Data Manually in Worksheet Cells

After you type numbers in a cell, you can change the format in which they are displayed.

1. Click the cell that contains the numbers that you want to format.
2. On the Home tab, in the Number group, click the arrow next to the Number Format box, and then click the format that you want.

   ![Number Format](image)

   **TIP** To select a number format from the list of available formats, click More, and then click the format that you want to use in the Category list.

**Format a number as text**

For numbers that should not be calculated in Excel, such as phone numbers, you can format them as text by applying the Text format to empty cells before typing the numbers.

1. Select an empty cell.
2. On the Home tab, in the Number group, click the arrow next to the Number Format box, and then click Text.

   ![Number Format](image)

3. Type the numbers that you want in the formatted cell.

   **NOTE** Numbers that you entered before you applied the Text format to the cells must be entered again in the formatted cells. To quickly reenter numbers as text, select each cell, press F2, and then press ENTER.