Microsoft Excel 2010:
Define and Use Names in Formulas

By using names, you can make your formulas much easier to understand and maintain. You can define a name for a cell range, function, constant, or table. Once you adopt the practice of using names in your workbook, you can easily update, audit, and manage these names.

Learn more about using names

A name is a meaningful shorthand that makes it easier to understand the purpose of a cell reference, constant, formula, or table, each of which may be difficult to comprehend at first glance. The following information shows common examples of names and how they can improve clarity and understanding.

<table>
<thead>
<tr>
<th>EXAMPLE TYPE</th>
<th>EXAMPLE WITH NO NAME</th>
<th>EXAMPLE WITH A NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference</td>
<td>=SUM(C20:C30)</td>
<td>=SUM(FirstQuarterSales)</td>
</tr>
<tr>
<td>Constant</td>
<td>=PRODUCT(A5,8.3)</td>
<td>=PRODUCT(Price,WASalesTax)</td>
</tr>
<tr>
<td>Formula</td>
<td>=SUM(VLOOKUP(A1,B1:F20,5,FALSE), -G5)</td>
<td>=SUM(Inventory_Level,-Order_Amt)</td>
</tr>
<tr>
<td>Table</td>
<td>C4:G36</td>
<td>=TopSales06</td>
</tr>
</tbody>
</table>

TYPES OF NAMES

There are several types of names that you can create and use.

**Defined name** - A name that represents a cell, range of cells, formula, or constant value. You can create your own defined name, and Microsoft Excel sometimes creates a defined name for you, such as when you set a print area.

**Table name** - A name for an Excel table, which is a collection of data about a particular subject that is stored in records (rows) and fields (columns). Excel creates a default Excel table name of Table1, Table2, and so on, each time that you insert an Excel table, but you can change a table's name to make it more meaningful.

THE SCOPE OF A NAME

All names have a scope, either to a specific worksheet (also called the local worksheet level) or to the entire workbook (also called the global workbook level). The scope of a name is the location within which the name is recognized without qualification. For example:

- If you have defined a name, such as Budget_FY08, and its scope is Sheet1, that name (if not qualified) is recognized only in Sheet1, but cannot be recognized in other sheets without qualification.

  To use a local worksheet name in another worksheet, you can qualify it by preceding it with the worksheet name, as the following example shows:

  Sheet1!Budget_FY08
Microsoft Excel 2010: Define and Use Names in Formulas

- If you have defined a name, such as Sales_Department_Goals, and its scope is limited to the workbook, that name is recognized for all worksheets in that workbook, but not for any other workbook.

A name must always be unique within its scope. Excel prevents you from defining a name that is not unique within its scope. However, you can use the same name in different scopes. For example, you can define a name, such as GrossProfit, that is scoped to Sheet1, Sheet2, and Sheet3 in the same workbook. Although each name is the same, each name is unique within its scope. You might do this to ensure that a formula that uses the name, GrossProfit, is always referencing the same cells at the local worksheet level.

You can even define the same name, GrossProfit, for the global workbook level, but again the scope is unique. In this case, however, there can be a name conflict. To resolve this conflict, by default, Excel uses the name that is defined for the worksheet because the local worksheet level takes precedence over the global workbook level. If you want to override the precedence and you want to use the workbook name, you can disambiguate the name by prefixing the workbook name, as the following example shows:

WorkbookFile!GrossProfit

You can override the local worksheet level for all worksheets in the workbook, with the exception of the first worksheet, which always uses the local name if there is a name conflict and cannot be overridden.

DEFINING AND USING NAMES

You can define a name by using the:

- **Name box on the formula bar** This is best used for creating a workbook level name for a selected range.
- **Existing row and column labels of a selection of cells** You can use the Create from Selection command to conveniently create names from existing row and column labels by using a selection of cells in the worksheet.
- **New Name dialog box** This is best used for when you want more flexibility in creating names, such as specifying a local worksheet level scope or creating a name comment.

**Note** By default, names use absolute cell references.

You can use a defined name in a formula by entering it as follows:

- **Typing** Typing the name, for example, as an argument in a formula.
- **Using Formula AutoComplete** Use the Formula AutoComplete drop-down list, where valid names are automatically listed for you.
- **Selecting from the Use in Formula command** Select a defined name from a list available from the Use in Formula command in the Defined Names group on the Formulas tab.

AUDITING NAMES
Microsoft Excel 2010:
Define and Use Names in Formulas

To keep track of all defined names in a workbook, you can create a list that displays all defined names and their locations.

1. Locate an area with two empty columns on the worksheet (the list will contain two columns, one for the name and one for a description of the name).
2. Select a cell that will be the upper-left corner of the list.
3. On the Formulas tab, in the Defined Names group, click Use in Formula, and then click Paste Names.
4. In the Paste Names dialog box, click Paste List.

Learn about syntax rules for names

The following is a list of syntax rules that you need to be aware of when you create and edit names.

- **Valid characters**  The first character of a name must be a letter, an underscore character (\_), or a backslash (\). Remaining characters in the name can be letters, numbers, periods, and underscore characters.
  
  **Note** You cannot use the uppercase and lowercase characters "C", "c", "R", or "r" as a defined name, because they are all used as a shorthand for selecting a row or column for the currently selected cell when you enter them in a Name or Go To text box.

- **Cell references disallowed**  Names cannot be the same as a cell reference, such as Z$100 or R1C1.

- **Spaces are not valid**  Spaces are not allowed as part of a name. Use the underscore character (\_) and period (\.) as word separators; for example, Sales_Tax or First.Quarter.

- **Name length**  A name can contain up to 255 characters.

- **Case sensitivity**  Names can contain uppercase and lowercase letters. Excel does not distinguish between uppercase and lowercase characters in names. For example, if you created the name Sales and then create another name called SALES in the same workbook, Excel prompts you to choose a unique name.

Define a name for a cell or cell range on a worksheet

1. Select the cell, range of cells, or nonadjacent selections that you want to name.
2. Click the Name box at the left end of the formula bar.

   ![Name box](image)

   **Name box**

3. Type the name that you want to use to refer to your selection. Names can be up to 255 characters in length. To learn about additional rules for creating names, see the preceding section, Learn about syntax rules for names.
4. Press ENTER.
Microsoft Excel 2010:
Define and Use Names in Formulas

**Note**  You cannot name a cell while you are in editing mode to change the contents of the cell.

### Define a name by using a selection of cells in the worksheet

You can convert existing row and column labels to names.

1. Select the range that you want to name, including the row or column labels.
2. On the **Formulas** tab, in the **Defined Names** group, click **Create from Selection**.
3. In the **Create Names from Selection** dialog box, designate the location that contains the labels by selecting the **Top row**, **Left column**, **Bottom row**, or **Right column** check box.

**Note**  A name created by using this procedure refers only to the cells that contain values and does not include the existing row and column labels.

### Define a name by using the New Name dialog box

1. On the **Formulas** tab, in the **Defined Names** group, click **Define Name**.
2. In the **New Name** dialog box, in the **Name** box, type the name that you want to use for your reference.

   **Note**  Names can be up to 255 characters in length. To learn about additional rules for creating names, see the section, Learn about syntax rules for names.

3. To specify the scope of the name, in the **Scope** drop-down list box, select **Workbook** or the name of a worksheet in the workbook.
4. Optionally, in the **Comment** box, enter a descriptive comment up to 255 characters.

   **Note**  If you publish the workbook to Excel Services and you specify one or more parameters, the comment is used as a ScreenTip in the **Parameters** Task Pane.

5. In the **Refers to** box, do one of the following:
Microsoft Excel 2010: Define and Use Names in Formulas

- To enter a cell reference, type the cell reference.

  **Tip** The current selection is entered by default. To enter other cell references as an argument, click which temporarily shrinks the dialog box, select the cells on the worksheet, and then click to restore the dialog box to its normal size.

- To enter a constant, type \( = \) (equal sign) and then type the constant value.

- To enter a formula, type \( = \) and then type the formula.

6. To finish and return to the worksheet, click **OK**.

**Tip** To make the **New Name** dialog box wider or longer, click and drag the grip handle at the bottom.

Manage names by using the Name Manager dialog box

Use the **Name Manager** dialog box to work with all of the defined names and table names in the workbook. For example, you may want to find names with errors, confirm the value and reference of a name, view or edit descriptive comments, or determine the scope. You can also sort and filter the list of names, and easily add, change, or delete names from one location.

To open the **Name Manager** dialog box, on the **Formulas** tab, in the **Defined Names** group, click **Name Manager**.

VIEW DEFINED NAMES AND TABLE NAMES

The **Name Manager** dialog box displays the following information about each name in a list box:

<table>
<thead>
<tr>
<th>THIS COLUMN</th>
<th>DISPLAYS:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Icon and Name</td>
<td>One of the following:</td>
</tr>
</tbody>
</table>

  - A defined name, which is indicated by a defined name icon.
  - A table name, which is indicated by a table name icon.

| Value | The current value of the name, such as the results of a formula, a string constant, a cell range, an error, an array of values, or a placeholder if the formula cannot be evaluated. The following are representative examples: |

University of New Mexico
College of Education

Andrea Harvey
garciaa@unm.edu
Microsoft Excel 2010:
Define and Use Names in Formulas

"this is my string constant"
3.1459
{2003;12,2002;23,,2001,18}
#REF!
 {...}

Refers To  The current reference for the name. The following are representative examples:

=Sheet1!$A$3
=8.3
=HR!$A$1:$Z$345
=SUM(Sheet1!A1,Sheet2!B2)

Scope One of the following:

A worksheet name, if the scope is the local worksheet level.
"Workbook", if the scope is the global worksheet level.

Comment Additional information about the name up to 255 characters. The following are representative examples:

This value will expire on May 2, 2010.
Don't delete! Critical name!
Based on the ISO certification exam numbers.

**Note**  If you publish the workbook to Excel Services and you specify one or more parameters, the comment is used as a ScreenTip in the Parameters Task Pane.

Notes

- You cannot use the Name Manager dialog box while you are changing the contents of the cell.
- The Name Manager dialog box does not display names defined in Visual Basic for Applications (VBA) or hidden names (the Visible property of the name is set to "False").

RESIZE COLUMNS

- To automatically size the column to fit the largest value in that column, double-click the right side of the column header.

SORT NAMES

- To sort the list of names in ascending or descending order, alternately click the column header.
FILTER NAMES

Use the commands in the Filter drop-down list to quickly display a subset of names. Selecting each command toggles the filter operation on or off, which makes it easy to combine or remove different filter operations to get the results that you want.

To filter the list of names, do one or more of the following:

<table>
<thead>
<tr>
<th>SELECT:</th>
<th>TO:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Names Scoped To Worksheet</td>
<td>Display only those names that are local to a worksheet.</td>
</tr>
<tr>
<td>Names Scoped To Workbook</td>
<td>Display only those names that are global to a workbook.</td>
</tr>
<tr>
<td>Names With Errors</td>
<td>Display only those names with values that contain errors (such as #REF, #VALUE, or #NAME).</td>
</tr>
<tr>
<td>Names Without Errors</td>
<td>Display only those names with values that do not contain errors.</td>
</tr>
<tr>
<td>Defined Names</td>
<td>Display only names defined by you or by Excel, such as a print area.</td>
</tr>
<tr>
<td>Table Names</td>
<td>Display only table names.</td>
</tr>
</tbody>
</table>

Change a name

If you change a defined name or table name, all instances of that name in the workbook are also changed.

1. On the Formulas tab, in the Defined Names group, click Name Manager.

2. In the Name Manager dialog box, click the name that you want to change, and then click Edit.

   Tip   You can also double-click the name.

3. In the Edit Name dialog box, in the Name box, type the new name for the reference.

4. In the Refers to box, change the reference, and then click OK.

5. In the Name Manager dialog box, in the Refers to box, change the cell, formula, or constant represented by the name.

   • To cancel unwanted or accidental changes, click Cancel, or press ESC.
Microsoft Excel 2010:
Define and Use Names in Formulas

- To save changes, click **Commit**, or press ENTER.

**Note**  The **Close** button only closes the **Name Manager** dialog box. Clicking **Close** is not required to commit changes that have already been made.

**Delete one or more names**

1. On the **Formulas** tab, in the **Defined Names** group, click **Name Manager**.

2. In the **Name Manager** dialog box, click the name that you want to change.

3. Select one or more names by doing one of the following:
   - To select a name, click it.
   - To select more than one name in a contiguous group, click and drag the names, or press **SHIFT** and click the mouse button for each name in the group.
   - To select more than one name in a noncontiguous group, press **CTRL** and click the mouse button for each name in the group.

4. Click **Delete**. You can also press the **DELETE** key.

5. Click **OK** to confirm the deletion.

**Note**  The **Close** button only closes the **Name Manager** dialog box. Clicking the **Close** button is not required to commit changes that have already been made.